What browser/plugins should I use/are needed?

Summary This article includes information on what browsers and/or plugins are recommended for using Sakai, CampusConnect, FacultyAccess, Office365 and other related services. Supported/Recommended browsers include: Firefox 21+ (download) Chrome 25+ (download) Internet Explorer 8+ (download) Safari 6+ (download) Required plugins include: Java 7 update 25 (minimum) (download) Flash 11 (minimum) (download) Silverlight 5 (minimum) (download) … Continue reading What browser/plugins should I use/are needed?

Advertisements